I Can not install the new version on my MACBOOK

I've been trying to install the ARDR app on my MACBOOK and it keeps telling me the installer from the website is damaged. Any ideas?

Can somebody help me please?

Anybody???

Try xattr -c <file>.dmg. If it doesn't work you can also try to append sudo to that command.

Thanks for your reaction. But sorry, I do not know what to do. What is : xattr -c <file>.dmg .

If it doesn't work you can also try to append sudo to that command.

What is sudo to that command?

(I am not a coder / programmer sorry)

with sudo you execute commands with super user rights, basically as admin.

you would use:
sudo xattr -c <file>.dmg

and would be asked for your password.

Those are command line orders. You need to open a terminal, and run that command to your downloaded dmg file.

@Almonte , could you provide some more details? I don't even know the name for the terminal app on MacOS. :grin:

Hi Dutchrotterdam,

You have to open a MacOS terminal:

  • Click Command + Spacebar.
  • Type Terminal and click enter

The MacOS terminal will appear, then navigate to the folder you downloaded the Ardor MacOS installer.
ie: cd Downloads/

Finally run the following command:

sudo xattr -c ardor-installer-2.3.4.dmg

Afterwards, you can open the installer normally

1 Like

Super, it worked!

thank you very much Alberto (and others) and best regards.

2 Likes

Hi Alberto,
When I do the indications you recommend, the next message appears on my screen: "Ardor-installer" is damaged and cannot be opened. Move it to the trash."
Any other recommendation?
Thanks!

Hi Ardorfan,

Can you please double check that you opened a terminal and you execute the command:

sudo xattr -c ardor-installer-2.3.4.dmg

It will asks for your password, once it is executed the Ardor installer will not prompt that error.

Kind regards and thanks for reaching out

Thanks for your fast reply Alberto. This is a screenshot of what appears on my screen:

Hi Almonte, I have had the same issue and tried the steps you suggested but have had no success. I had to reinstall Ardor as the app crashed on my MacBook but I can't move it to Applications without getting the same error message listed above. Any ideas? Don't want my ARDR locked away forever

Hi Jjpp1234,

Thanks for reaching out. We have just tested the installation process in macOS Big Sur Version 11.5.2. You can find some issues if there was a modification of the file so please follow the instructions as it is the safest way to install the software:

  1. Delete your current Ardor app, and the installer file ardor-installer-2.3.4.dmg

  2. Download the Ardor installer from the Jelurida webpage. The link is https://www.jelurida.com/ardor-installer.dmg

  3. Execute the command sudo xattr -c ardor-installer-2.3.4.dmg in the terminal
    image

  4. Double click on the ardor-installer-2.3.4.dmg file

  5. Double click on ardor-installer.app

  6. The installer will be prompted. Follow the instructions to complete the installation of the software: Getting started

Let me know if it works

Hi! Same problems on mac!
And web version says api has been disabled so I can't send my ardors, would you help?

Welcome to the community Nick,

The ardor.jelurida.com web is a read-only wallet:

However, the MacOS versión has been already tested with the instructions above and it worked. Perhaps deleting the former Ardor.app makes the Ardor software install again.

Kind regards