Starting the blockchain

Hello sir
i want to understand ardor performance better and try playing with some variable changes on a separate copy of the blockchain. I compiled my version of ardor with new blocktimes, new epoch time, new ports, and only one childchain with more transactions per childchain allowed. Everything works there and I have that verison running on 2 nodes that can see each other; is connected and transferring data between each other. I split the 1,000,000,000 tokens each into 200,000,000 of the parent and childchain tokens between 5 accounts. I can login to the ui and enable forging for any/all accounts and the terminal shows forging enabled, but the chain never moves. It just stays at block 0 with no error messages or warnings. The forging enabled message in the terminal also looks odd with 0s

FINE: Forger 2766217825807328998 deadline 0 hit 0 started

Did you set in conf/data the public keys of the owners of the parent chain coins?

Try to debug why the hit and deadline of the Generator instance are 0

Hello sir
Thank you for your response. Yes this is the parent chain coins file


This is the PUBLIC_KEY.json file that has the public keys for the 5 accounts


Thinking about your hit and deadline being 0 comment I look at the file and saw Constants.LAST_KNOWN_BLOCK. I changed that to 0 and now i get on first node with first account

 FINE: Forger 3705364957971254799 deadline 34 hit 34 started

I tried the second on a second node and get

FINE: Forger 2766217825807328998 deadline 71 hit 71 started

the blockchain still does not move though. It stays at Height 0. Nothing more in terminal output. Is there a log value to change for more DEBUG information?

Thank you sir for the help

If it comes to testing, you may want to leave the JPL license.
I don't know if it's the same for NXT and Ardor but have you tried these steps?

In genesisAccounts.json:

    "balances": {
         "NXT-NZKH-MZRE-2CTT-98NPZ": 30000000000000000,
         "NXT-X5JH-TJKJ-DVGC-5T2V8": 30000000000000000,
         "NXT-LTR8-GMHB-YG56-4NWSE": 30000000000000000
     "publicKeys": [

In genesisParameters.json:

"epochBeginning":"2021-11-11 12:00:00 +0000"

In genesisAccounts.json enter your public key addresses.

In genesisParameters.json only the date must be changed, it seems to me it is better not to go beyond 800-1440 blocks. (24 hours)

For safety, delete the nxt_db / ardor_db, delete temporary files.
To boot

Hello sir

It is different and does not have those files

i figured it out. I did not have enough peers

I seem to remember that maybe in Ardor the .json was encoded differently but maybe I'm wrong?
I tried looking inside the .json, I'm not sure but I think for you the files are:
"genesisAccounts.json" converted to = "Ardor.json" / "Ignis.json"
"genesisParameters.json" converted to = "PUBLIC_KEY.json"

Maybe the doors are the same? If so, your version of Aardor may mix with the original version of Aardor.