No adress info for my account

Hello,

It`s been a long time since I log into my ardor wallet.
I can access by inserting my Public Account Adress.
If I want to make a withdrawl from my wallet it says:
Incorrect Passphrase (belongs to Account ARDOR-...)
This actually is not possible since I only have this Information I got by making an account years ago. And at that time everthing worked fine. (My transaction history can be displayed).
My wallet is still downloading the blockchain since my last login. Could this be an issue with my topic?
When I go to more info, it says the following in the screenshot.
Is there a workaround to export my private key or passphrase from my ardor wallet?

Thank you in advance.

Best,
Daniel

Okay. Blockchain got downloaded completely. But still, it says my Private Key and Passphrase is not available.
But I actually have them in my files which are backed up multiple times. They all have the same data. There is now way, I have another ardor account and got things mixed up...

Hi Daniel,

Please check that you are login to your old account clicking on the Passphrase tab, see the tutorial as follows: Login Page Tutorial

And also check that the passphrase is correct and it does not have any additional character such as white spaces.

Kind regards,
Jelurida Support Team

Hi,

thank you for your response.
But still it is not working. There are for sure no additional characters in my passphrase. I checked it.
When I insert my passphrase into the login page I get this:

Login with the above mentioned account (screenshot) I have no funds.
Login with my normal account I have for years I have funds but no corresponding passphrase (which is impossible because I have them backed up...) How is this possible?

Dealing with Passphrase Problems

Due to the decentralized design of the blockchain, the user is the only one who received the secret passphrase during the creation of a new Ardor account with the default Ardor client. There is no way for anyone to restore or reset the passphrase, not even for the developers. So if the passphrase is lost, it is impossible to make transactions from the account.

Every combination of characters opens a different Ardor account. So if you mistakenly add an extra space at the end of your passphrase, or make a small typo, you will open a different Ardor account.

The default Ardor passphrase consists of 12 random English words out of a 1600+ words dictionary. This is impossible to crack by brute-forcing. Only if you think you made a small typo, or if you forgot for example 1 of the 12 words, it might be possible to find the correct passphrase by brute-forcing it. Some community members made tools for this, for example, Typo Finder (which needs the public key), and Ardor itself provides a basic password recovery tool Passphrase_Recovery.

If your passphrase and the account that has your ARDR don't match, you are either using the wrong password, or you sent your ARDR to the wrong account by mistake, thinking it was your account.

For example: You create the account, and passphrase A is shown on the screen. You enter it in the client the first time, but you, unfortunately, make a small typo, so you end up in account B. Every combination of chars opens a new (empty) account. You think passphrase A matches account B, so you send your tokens to account B. Now when you enter your passphrase for A without the typo, it doesn't work for account B. When you login with passphrase A, you end up in the real account A, which has 0 ARDR in it. You could try to find out what password B (with the typo) is, that gets you to account B with the ARDR in it, but you'll have to be lucky to find the typo.

The best way to prevent this is to always REALLY make sure you REALLY control your account that has the passphrase. Just send 1 small outgoing transaction from the account before you even put large amounts of funds in it. By the way, the client DOES strongly recommends you to do an outgoing transaction in order to publish your public key to the blockchain for new accounts.

Hey,

Thank you for your answer.
But this still does not explain why I dont see my passphrase for my account (see first screenshot of my issue) in the first place. This account has transactions on it I did 4 years ago. And at that time everthing worked fine...

Hi Daniel,

I regret to say that the only possible reason is that the passphrase you typed 4 years ago is different from the one you are typing now. However it can be a typo, you can try to find it with the community tool Typo Finder

Kind regards

Hey,

I tried the typo finder. Everything looks good. It says that there is nothing wrong with my passphrase that is linked to my account...
I am confused...

There is one special case for which a passphrase which worked 4 years ago doesn't calculate to same account today: if you didn't use the auto-generated 12-words back then but used your own passphrase which is exactly 64 characters hex string. Maybe this is the case? Here is related changelog and what to do today:

For passphrase accounts, the private key is calculated using sha256 hash plus
some bit manipulation (clamp), therefore every passphrase can be converted to
a private key but a private key cannot be converted back to a passphrase.
Whenever entering a passphrase in the wallet it is possible to enter the 64
characters private key hex string instead. To enter old 64 character passphrase
composed of exactly 64 characters hex string, prefix it with the string
"Passphrase:" (without quotes).