blockchain download halted, not connecting [SOLVED]

I have just downloaded 1.12.3 (again), and compiled and run it on Linux. My firewall has all the necessary ports open. I have not touched the nxt.properties file at all, because I am not sure what the problem is now, hence I left the nx-default.properties file untouched, thinking that using an unmodified copy of 1.12.3 would work successfully, and that I could modify the .properties specs to find out where I had mad a mistake. But something is still wrong. I can open the GUI etc. But it says "not connected, blockchain halted". And the ufw IS open for the ports 47874 (peer port) and 7876 (SSL and normal API port).

I wonder what is wrong? I honestly don't know. I had no problem a year ago getting my clone running with its own 900 million units. I'm really curious also if 1.12.2 is available to download somewhere? I'm a bit weirded out because firewall is open for those ports, and I didn't touch the doc, all the dependencies are installed as I previously did when connecting to my own blockchain and forging successfully, etc.

Does someone maybe have a list of known peers I can add to the file, I think that is obviously the problem but why is it that the peers aren't already in the properties file to successfully sync on the go?

Here is the list of peers I've just added - I'm shocked it says its FINE that I've failed to resolve peer address of nxt.jelurida.com - is it no longer accepting peer connections on port 47874?

108.53.198.223; 197.89.108.228; 80.98.42.201; 88.99.225.142;
87.138.221.20; nxt2.bamdwurn.tk; 76.108.233.84; 51.38.163.49; 138.68.3.178;
nxtx.ru; nxt4.y.cz; 213.168.251.105; nxt01.now.im; 195.62.123.155;
86.178.133.90; 1.41.128.121; 174.140.167.239; 93.123.80.47; 162.243.242.8;
159.65.126.29; 72.42.167.190; 39.109.206.215; nxt.utila.nl; 212.186.184.152;
nxtnode002.ddnss.eu; 110.174.129.213; 178.150.207.53; nxt3.y.cz;
149.56.128.11; 98.7.24.252; nxtpeer.duckdns.org; 68.195.28.248;
102.177.134.221; 68.132.119.38; 112.141.4.128; nxt.jelurida.com;
91.139.128.190; 178.91.67.246; 176.9.85.5; 85.11.147.38; 108.161.166.82;
62.195.14.95; 83.162.253.185; nxtnode004.ddnss.eu; nxt.nodes.mycrypto.space;
172.245.181.157; enricoip.no-ip.biz; 115.201.66.89; 220.134.112.220;
107.146.192.126; 85.145.209.39; www.ardorwallet.com; nxtnode007.ddnss.eu;
43.251.107.151; 162.243.194.123; 73.172.245.27; 103.250.83.112;
177.189.157.183; 136.243.249.132; 185.86.151.145; nxt1.testdruif.be;
23.92.65.249; 87.15.96.164; nxtnode006.ddnss.eu; 80.101.149.84;
47.254.130.44; 87.138.143.21; 193.112.110.100; 68.145.247.42;
nxt1.chain.garden; 175.212.197.119; lewis-home.servebeer.com; 216.170.122.9;
204.44.93.99; 188.0.160.90; 87.140.100.223; 86.130.23.118; 70.122.109.39;
36.248.61.251; 77.81.230.151; 59.110.42.19; 212.232.49.28; 86.17.121.86;
101.132.159.206; 176.94.115.161; 220.253.112.140;
phvll7lsuuvlqpfo.myfritz.net; 47.91.239.124; 188.166.43.41; 176.101.58.61;
87.222.27.197; nxtnode005.ddnss.eu; 38.87.54.163; 176.62.179.140;
nxtnode003.ddnss.eu; 185.254.97.12; 134.249.150.151; dud1401.ddns.net;
84.201.37.90; nxt.miasik.tk; 80.211.145.9; 217.26.24.27; 108.61.208.248;
34.244.14.14; 92.249.89.44; 94.45.222.203; 73.140.62.110; 208.123.231.66;
185.170.113.79; 185.62.37.164; 61.171.198.82; nxt.notbot.me; 188.68.32.148;
85.25.200.125; 91.236.145.141; 109.230.199.49; 217.182.93.187;
172.105.225.12; 217.182.72.43; 144.217.162.55; 192.99.58.223;
67.184.135.104; 2.92.29.17; 185.82.22.247; 70.52.85.100; 138.197.106.19;
138.197.3.59; 118.17.123.6; 60.70.98.88; 188.186.70.172; 164.132.45.10;
34.207.167.93; 31.214.157.83; 100.34.230.160;
144.217.162.55; 143.110.218.195; \

Because the peer port in 1.12.3 is 47874 and not 7874 like I had assumed it had been if I remember correctly in previous versions?

It still says "blockchain download halted, no connection" althoughj I do get database pool current size: 6 in terminal.

Is 47874 the correct peer port for NXT? or is it 7874?

If you want to run a clone you don't need to have peers from the official blockchain.

In your clone you have to put the peers of your users if you have any ..

The official peers are only for the JPL license which you will activate from the nxt.addons.JPLSnapshot function, the function if set correctly will do everything by itself.

'lol' hi Lorenzo. I am aware of that and have previously had my own clone with multiple nodes. However I'm trying to connect to the NXT blockchain in order to do my JPLSnapshot airdrop etc. for the genesisAccounts.json, and I'm having a problem connecting, but the clone is untouched and also the UFW (firewall) is open, so I don't know what the problem is.

He understood, well explaining it with 2 lines is not easy.
Try following:

The third video explains how to disable or enable certain services, but when it explains how to change the name of the cone it is not exactly the correct way.

Problem solved:
"nxt.myAddress= 0.0.0.0
this was the problem. I did not set it to my specific IP address.

I had assumed that like peerServerHost=0.0.0.0 it would listen and find it automatically...

lol no if I leave it it is autodetected. I remember now. Sleeping pills are ruining my memory. oh goodness.