ardor node reward program

I am trying to get the node rewards program running, but when I sent me encrypted message I have not gotten a response back yet and its been 5 days. When I try to send another one the contract reference box does not show up anymore. Am I doing something wrong? Below is my screen shot.

The last message which was not responded is from March 30th - transaction id 2:1b7f9e4ea3f759a24c012b55b14654ce3e59acd14bb78495dde313ecd02a30c9. The problem there is that the IP address in nodeAddress is invalid.

About the "Contract Reference" box not appearing - it's probably a bug, but I cannot reproduce it on my side. I need more details like how you enter "@noderewardardor" and and do you use a browser or the desktop application?

I am using a chromebook, so the android apk as a full node. When I put in the recipient name, I delete the ARDOR part and manually type in @noderewardardor. It worked for me the first time. I recently updated to 2.4.1 as well.

I tried the akp but not on Chromebook. It seems to work on regular Android device.

You can enter the message without activating the contract reference box:

  "contract": "NodeReward",
  "params": {
    "nodeAddress": "[String]"

and don't forget to write your IP in "nodeAddress"

will the reward program accept ipv6? Just want to try it and see if my ipv4 is the issue.

actually i got it to work. I realized i wasnt using my public IP.

1 Like

ipv6 - no

one last thing I don't know where ardor gets installed on chromebook so I can't change the file. Would you happen to know?

I don't have Chromebook but when you start the apk you should see a screen with several buttons, first one is "configure". Press it and then you should see "edit configuration" option. Try to use that. Please report back if it works.

I figure it out, so for future reference if anyone uses a chromebook this is how you find the folder.
Go to my files then in the top right corner is three vertical dots. Click on the dots and a drop down menu shows. Make sure show all play folder is checked. Then go to My Files > Play Files > Android > Data > > Files > Conf